Page tree
Skip to end of metadata
Go to start of metadata

Achtung! Diese Anleitung funktioniert so nicht. Work in progress.


Diese Anleitung soll zeigen, wie an den Ports des internen Switch unterschiedliche Netze konfiguriert werden können.

In diesem Beispiel wird an Port 1+2 das MESH-Netz und an den Port 3+4 das Client-Netz ausgeleitet. Hierzu wird ein TP-Link WR-841N V11 genutzt.

Je nach Router werden andere interne Bezeichnungen für die Ports genutzt. Auf den Seiten von OpenWRT kann unter der Überschrift "Switch configuration" die passende Bezeichnung gesucht werden.

Vorbereitung

  • Der Router muss mit den Default-Einstellungen im Bezug auf MeshOnLan / MeshOnWan konfiguriert sein
  • Ein SSH-Schlüssel muss hinterlegt sein
  • Per SSH verbinden
  • Falls gewünscht die alte Konfiguration sichern

/etc/config/network editieren

Port 3+4 (interne Ports 1+2) aus dem Mesh-Netz (Default beim Freifunk Münsterland) entfernen und das Port der CPU auf tagged umstellen.

Dazu Zeile 4 suchen und anpassen:

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 3 4'

Port 1+2 (interne Ports 3+4) untagged sowie das Port der CPU tagged auf ein neues VLan 3 konfigurieren:

config switch_vlan
	option device 'eth0'
	option vlan '3'
	option ports '0t 1 2'

Das neue VLan 3 im Client-Netz konfigurieren. Dazu die Zeile 4 suchen und anpassen:

config interface 'client'
        option type 'bridge'
        option macaddr 'ec:08:6b:69:23:c6'
        list ifname 'bat0 eth0.3'
        option proto 'dhcpv6'
        option reqprefix 'no'
        option robustness '3'
        option query_interval '2000'
        option query_response_interval '500'
        option peerdns '1'
        option sourcefilter '0'
  • No labels